Garçon devant un ordinateur.jpg
LeSavant.svg

la cabane  •  le Savant  •  le Livre d'or

Participez ! Cet article, comme tous les articles de Vikidia, est peut-être incomplet et tu peux l'améliorer. Tu as des connaissances sûres sur le sujet (texte ou illustration) ? Alors n'hésite pas à les ajouter. Ta contribution est la bienvenue ! C'est à toi de jouer ! Clin d'œil

Vikidia:Problèmes techniques

Aller à : navigation, rechercher

Cet espace est destiné aux problèmes techniques non encore résolus.

  • Pour les problèmes nécessitant la simple intervention technique d'un administrateur (suppression de page aberrante, intervention sur une page système ou protégée) , voir la page dédiée aux demandes aux administrateurs

Il y a 68 tickets, dont 7 ticket(s) en attente et 9 ticket(s) en cours de traitement.
Pour faire une requête, rapporter un bug, demander la modification d'un filtre,
> créez un ticket <

Problèmes en cours[modifier]

Erreur de syntaxe dans la base de données[modifier]

Il arrive que sur l'affichage de certains articles on obtienne un message :

« Erreur de syntaxe dans la base de données. La dernière requête traitée par la base de données était : «
« (requête SQL cachée) «
« depuis la fonction « Parser::replaceLinkHolders ». MySQL a renvoyé l’erreur « 1271: Illegal mix of collations for operation ' IN ' (localhost) ».

Le problème est lié à la présence de caractères spéciaux inconnus dans l'article, et peut être réglé ainsi :

Micadiscuter 25 octobre 2007 à 13:53 (CEST)

Vikidia:Bavardages/Semaine 45 2007, 9 novembre 2007 vers 17:04 UTC[modifier]

Même message d'erreur, lié à un message de KoiNonne.

Je parviens à supprimer le texte incriminé en utilisant l'astuce ci-dessus, ce qui rend la page courante de nouveau visible. À 17:13 UTC, je préviens KoiNonne.

En tentant de copier le message de KoiNonne sur Discussion Utilisateur:KoiNonne, je reproduis l'erreur, puis je découvre qu'en supprimant le lien [[Discuter:Ruminant‎]] ça remarche. Je n'ai repéré aucun caractère exotique dans son texte.

Néanmoins la page d'historique de Vikidia:Bavardages/Semaine 45 2007 génère tjs le même message d'erreur. Je prends alors la décision de supprimer la page, dans le but de purger l'historique des contribs problématiques. Malheureusement, Special:Undelete/Vikidia:Bavardages/Semaine_45_2007 génère le même message d'erreur, et je suis incapable de restaurer la page (119 versions proposées à la restauration à ce moment là).

Je lance alors un SOS directement sur Vikidia:Bavardages. Après moultes tentatives de plusieurs personnes, Immunoman parvient à restaurer une version que je pense être celle qui précède le pb. Mais l'historique est perdu.

--GaAs354 10 novembre 2007 à 11:39 (CET)

Poème symphonique, 12 janvier 2008[modifier]

La page n'était plus accessible. Après diverses manips d'effacement / restauration, ayant donné des résultats étonnants (je coche 3 versions à restaurer, et ça en restaure 7...) la page refonctionne. Mais en cliquant dans l'historique de Poème symphonique, j'obtient ça :


BugVkd200801121.png

Mmmmmm...--GaAs354 12 janvier 2008 à 17:06 (CET)

Pour le nbre de versions restaurées et le message, c'était un pb de cache.Par contre, pourquoi cette page faisait planter MySQL ? Mystère. --GaAs354 12 janvier 2008 à 17:32 (CET)

J'ai créé un modèle pour tracer ces probblèmes[modifier]

{{BugBdD}}, qui catégorise en Catégorie:Page boguée. --GaAs354 12 janvier 2008 à 17:56 (CET)

Problème avec l'apostrophe[modifier]

En haut des articles dont le titre contient une apostrophe on peut lire : « Douze travaux d#39;Hercule » expliqué par Vikidia, l'encyclopédie pour les enfants., par exemple. Thomas 23 janvier 2008 à 21:38 (CET)

Je confirme, cf Douze travaux d'Hercule. --GaAs354 24 janvier 2008 à 12:49 (CET)

Problèmes réglés[modifier]

Identification d'IP de contributeurs enregistrés[modifier]

Bonjour, je m'interroge sur un faux-nez possible. Peut-on facilement comparer les IP de deux comptes et, si oui, comment ?--Flodelaplage 13 août 2007 à 18:56 (CEST)

Facilement, non, c'est une fonction à installer, mais qui le sera bientôt je pense. Astirmays 14 août 2007 à 20:41 (CEST)

Voir aussi les archives : Vikidia:Problèmes techniques/Archives/04 2007

Prolonger la recherche vers Wikipédia[modifier]

Quand on demande la consultation d'un article qui n'existe pas, la page "Résultat de la recherche" propose de rechercher l'article sur Wikipédia. Mais le nom de l'article recherché n'est pas propagé, il est remplacé par "Search"; on va donc vers http://fr.wikipedia.org/wiki/Special:Search?search=Search --Mica 21 mars 2007 à 21:11 (CET)

La prolongation de la recherche vers Wikipédia fonctionne en utilisant le paramètre $1 (message système modifié MediaWiki:Noexactmatch ).

Mais il reste un problème quand il y a des blancs dans le titre de l'article : par exemple en recherchant Ève Curie, on arrive sur l'article WP:Ève.

{{PAGENAMEE}} ne marche pas, il passe "Search" au lieu du nom de l'article recherché.
Une idée ? Micadiscuter 15 mai 2007 à 18:08 (CEST)


Derniers paramètrages[modifier]

En principe, ParserFunction est installé (ça n'a rien bloqué, pas mal !) Par contre pour ImageMagick, je n'ai pas tout compris. Il n'y a que la page [1] qui en parle vraiment, avec comme "Default Value" : '/usr/bin/convert' ; il y a un répertoire bin, mais pas pas de convert dedans, et je n'ai pas trouver où le copier si c'est ce qu'il faut faire. Astirmays 5 avril 2007 à 22:15 (CEST)

Et pour les références ? 1--Micadiscuter 5 avril 2007 à 22:22 (CEST)

  1. Si ça fonctionne, c'est que ça marche ~~~~

Pour ImageMagick, il faut d'abord que tu aies prendre le package adapté. Je ne sais pas sous quoi tourne le serveur, je suppose Linux, enfin tu trouveras ce qu'il faut là-bas : http://www.imagemagick.org/script/binary-releases.php ou http://www.imagemagick.org/script/install-source.php - Après l'installation, tu devrais avoir convert, il se peut que tu aies à modifier le chemin vers le binaire dans le fichier de config de Mediawiki (si jamais, tu tapes "whereis convert" sous Linux). Dake 6 avril 2007 à 10:22 (CEST)

ps. dis-moi si tu as besoin d'aide pour l'installer. Dake 9 avril 2007 à 22:46 (CEST)
Je reviens sur imagemagick ; en fait je ne sais pas quel fichier télécharger aux pages indiquées... Pour info, l'hébergeur est : http://www.haisoft.fr ; si vous avez une idée... Astirmays 4 mai 2007 à 23:27 (CEST)
Ok, je crois que le /bin que tu as est en fait destiné aux "cgi-bin" (des programmes en C). Le problème c'est qu'Imagemagick, il faut pouvoir l'installer sur le système qui fait tourner Vikidia, et pour ceci il faut avoir un accès au shell, ce qui ne me semble pas possible si je me réfère à la page de l'hébergeur (ce n'est d'ailleurs plus de l'hébergement à ce moment mais carrément la location d'un petit serveur, cf. ovh.com). Bon :/ c'est pas la fête et je crois qu'il faut vraiment songer à demander du côté de la fondation s'il n'y a pas moyen de transférer Vikidia là-bas - ou se passer d'Imagemagick ainsi que de LaTeX d'ailleurs. Dake 10 mai 2007 à 16:07 (CEST)


Problème avec les images[modifier]

Je pense qu'il y a un petit souci avec Imagemagick. Exemple : Kfm.png. Maintenant si on regarde l'image Image:kfm.png sous Firefox, on voit qu'on a perdu des couleurs (avec IE c'est encore pire, il y a carrément des "trous" de transparence dans l'image). J'ai l'impression que le redimensionnement fait passer les images en 8 bits mais c'est une supposition (mis à part les couleurs, la qualité du redimensionnement n'égale pas celle sur Wikimedia, il y a peut-être des options à retoucher), il faudrait regarder les logs sur le serveur pour voir s'il n'y a pas des erreurs. Dake 24 mars 2007 à 12:07 (CET)

Ah en fait on n'utilise pas Imagemagick si je me réfère au fichier de config mais la lib GD de PHP. Ca serait mieux via Imagemagick amha, si on peut l'installer bien sûr. Dake 24 mars 2007 à 12:12 (CET)
Ça ressemble plus à bug qu'à autre chose. Il semble que cela vienne d'une mauvaise gestion de la transparence, les autres images n'ont pas ce problème, non ? Quant à Imagemagick (et le programme convert) c'est justement lui qui n'était pas présent sur le serveur. Thomas 24 mars 2007 à 12:48 (CET)
Si, il y aussi des problèmes avec d'autres - uniquement des icônes pour moi. Par ex, sous Camino, quand je regarde la Catégorie:Icône, Image:Icone Technique2.png est en noir et blanc. (idem sous Safari)--Mica 24 mars 2007 à 13:02 (CET)
Image:Icone Technique.png s'affiche bien dans la cat, par contre dans {{ébauche}}, je la vois en N&B. C'est toujours du type png.--Mica 24 mars 2007 à 13:08 (CET)
Ton exemple utilise la transparence. Seule les png sont touchés parce que c'est un des rares formats à gérer un canal alpha. Thomas 24 mars 2007 à 13:58 (CET)


Voilà, il n'y a plus le bug d'hier, (merci Dake et Ixnay) mais est-ce que CharInsert est opérationnel ? Astirmays 24 mars 2007 à 13:52 (CET)
Oui superbe ! Ix₪aΨ 24 mars 2007 à 14:01 (CET)
Idem, c'est super !! --Mica 24 mars 2007 à 14:17 (CET)

Bip, je relance le bug report :) Dake 29 mars 2007 à 21:34 (CEST)

Problème image[modifier]

déplacé de ma page de discussion

Salut, je reviens avec ces histoires d'images mal converties car c'est vraiment gênant pour refaire l'accueil. J'ai un peu regardé la doc de Mediawiki et il y a peut-être une alternative :

$wgThumbnailScriptPath - Give a path here to use thumb.php for thumbnail generation on client request, instead of generating them on render and outputting a static URL.

Dans Mediawiki-1.10, il y a un "thumb.php" qui se trouve à la racine (avec les README et autres). [2]

On aurait donc :

$wgUseImageResize      = true;
$wgUseImageMagick      = false;
$wgThumbnailScriptPath = "$wgScriptPath/thumb.php"; <--- il faudra tester (inspiré de http://hg.seoparts.com/dir/www.2emediawiki.2eorg/wiki/Manual:.24wgThumbnailScriptPath)

Pour tester : Iconthemes.png Iconthemes.png

Cordialement, -- Dake 23 juillet 2007 à 21:27 (CEST)

Voilà, j'ai modifié LocalSettings.php, voir la copie ici : Projet:Paramétrage et le diff. Ça n'a pas tout arrangé si ? Astirmays 28 juillet 2007 à 10:28 (CEST)

Pologne[modifier]

Bonsoir, le lien vers l’article sur la Pologne ne marche plus. J’espère que n’ai pas fais de bêtises. 77.205.6.111 30 novembre 2007 à 01:28 (CET)

Problème technique, pas de ta faute. Mort de rire
Faut attendre que ce soit réparé. Merci de l'avoir signalé ! --ironie 30 novembre 2007 à 03:41 (CET)
C'est réparé provisoirement ! C'est le caractère dans la monnaie polonaise Zloti qui posait problème. Attends avant de le remettre  !
Pour les admins : un caractère bizarre, qui fait (peut-être) planter. Voir page d'erreur, historique et WP, pour le caractère en question. --ironie 30 novembre 2007 à 03:47 (CET)
Merci ironie. Il faut qu'on fasse quelque chose pour ce problème. Moez m'écrire 30 novembre 2007 à 06:29 (CET)

Ébauche société[modifier]

Coucou,

Tous les articles comportant le portail société étaient catégorisés « ébauche société ». Ils pointent maintenant vers société, ce qui m'a paru plus logique. J'espère n'avoir pas fait de bêtises et qu'il s'agissait d'un oubli... Thomas 8 janvier 2008 à 21:15 (CET)

conflit de version[modifier]

lorsqu'on travaille sur deux ordi différents sur le même thème,il y a conflit de version car une seule version est retenue de l'article. l'autre est ignorée. Y a t il une solution? − Ce message non signé a été ajouté par Rachel (d · c · b).

Si vous travaillez sur le même article en même temps depuis deux ordinateurs différents, les conflits de version ne peuvent être évités. Le travail enregistré sera celui enregistré en premier. Faites-vous partie d'un établissement scolaire, si oui lequel ? --Flodelaplage 18 mars 2008 à 10:56 (UTC)

Modèle:User est planté ...[modifier]

Fatal error: Maximum execution time of 120 seconds exceeded in /var/www/vhosts/vikidia.org/subdomains/fr/httpdocs/includes/Parser.php on line 2840

Un Sysop pourrait régler ca ? je peut plus y travailler ... Vivi-1 (Discuter | Contributions) Posté le 6 avril 2008 à 11:58 (UTC)

Pas besoin de robot pour obtenir ce genre de message :) moi j'ai ça plusieurs fois pas jour comme simple utilisateur. Génréalement je fais quelques donnes de poker en ligne et quand je reviens, c'est débloqué... KoiNonne 6 avril 2008 à 12:03 (UTC)
Non c'est la BDD qui plante :S Vivi-1 (Discuter | Contributions) Posté le 6 avril 2008 à 12:10 (UTC)
Non, c'est un bug dans la fonction parser, qui fait tourner en boucle le programme. Fais un bug report. Pour corriger, tape directement http://fr.vikidia.org/index.php?title=Mod%C3%A8le:user&action=edit tu passes au-dessus du parser. Thomas 6 avril 2008 à 17:18 (UTC)
Eh, j'en ai une bonne ^^ ca replante quand on veut le modifier ... je sens que ça va m'amuser ca ... Vivi-1 (Discuter | Contributions) Posté le 7 avril 2008 à 14:11 (UTC)

Galerie d'images dans Achille[modifier]

En mode invité (mais pas seulement), Achille dispose d'une nouvelle fonction. Lors de l'import d'images, il suffit de cliquer sur Afficher une galerie pour faire une pré-sélection des images qui seront proposées à l'import. La galerie se présente sous forme d'une liste d'images avec une pré-visualisation en petit, par page de 20 images. Ceci est bien pratique et assez sympa pour les catégories de commons trop longues. À tester, j'attends vos retours, positifs ou négatifs (non-testé sous explorer, mais ça devrait fonctionner). Bonne nuit ! Thomas 9 avril 2008 à 23:03 (UTC)

Retour négatif (désolé, mais ça a l'air d'un outil intérressant). Je me suis contenté d'importer une image sur la Finlande. Et il m'a demandé de patienter ... Puis rien. Chuis pas trop sûr de ça, moi ! Bonne nuit. Content Octozor 9 avril 2008 à 23:06 (UTC)
Il faudrait que j'en sache plus. Donne-moi la page de commons, et également ton navigateur, enfin le max de détails. C'est peut-être simplement un message d'erreur que j'ai oublié. Chez moi, Category:Finland me donne 61 images trouvées. Thomas 9 avril 2008 à 23:12 (UTC)
Je viens de copier via la "galerie" une image tristounette (un nom de gare bizarre) de Finlande et ça marche. Je précise que j'utilise un bon vieil IE6 de... 2004 ;-))) Naturellement on peut la supprimer dès qu'Octozor sera repassé. KoiNonne 10 avril 2008 à 00:45 (UTC)
Je pense avoir trouvé un bug qui peut expliquer l'échec de l'import des images. À retester Thomas 10 avril 2008 à 17:15 (UTC)
Ça fonctionne : j'ai importé des images de rennes. (Belles bêtes, hein ?) Octozor 10 avril 2008 à 17:21 (UTC)

Erreur de la base de données[modifier]

Hello,

J'ai voulu apporter des changements à l'article Kranj mais une erreur de base de données apparaît :


Erreur de syntaxe dans la base de données. Cette erreur est peut-être due à une requête de recherche incorrecte (voir $5) ou une erreur dans le logiciel. La dernière requête traitée par la base de données était :

(Requête SQL cachée)

depuis la fonction « Parser::replaceLinkHolders ». MySQL a renvoyé l’erreur « 1271 : Illegal mix of collations for operation ' IN ' (localhost) ».


Les modifications que j'ai apportées sont les suivantes.

Il suffit d'enlever les balises nowiki pour faire apparaître l'erreur, étant donné que la version comportant l'erreur ne s'affiche pas dans l'historique. Vous pouvez tester sur ma page de brouillon.

Merci d'avance et bon courage. --Fabusnow 29 décembre 2008 à 20:42 (UTC)

Je ne crois pas que cela ait un rapport direct : voir néanmoins ceci sur le blog de Darkoneko. --Szyx 29 décembre 2008 à 22:31 (UTC)
Arf, d'accord, merci pour la réponse. Pour l'instant, ça me bloque, je ne peux plus avancer mais je serai patient. --Fabusnow 30 décembre 2008 à 00:41 (UTC)
Bonjour. Cette erreur me semble indépendante du déménagement serveurs (car il n'y a rien lié aux base de données dans ceux déplacés, uniquement des proxys). J'ai tenté un dummy edit sur l'article et n'ai pas rencontré de problème
Si vous retentez avec la modification ayant causée le souci et que le problème persiste, il faudra sans doute ouvrir un bug report. D'après ce que j'ai lu, la fonction gère tout ce qui est en rapport avec le traitement des liens internes, catégories et interwikis ; donc je suppose que le problème viens de ces morceaux de syntaxe.
Cdlt, w:fr:user:Darkoneko 30 décembre 2008 à 07:13 (UTC)
Re-bonjour. Après divers tests, je me suis rendu compte que le problème venait quand on wikifiait Jože Plečnik en lui attribuant un lien interne de la sorte : [[Jože Plečnik]]. Le problème viendrait notamment du č qui n'est pas pris en compte car Jože Plecnik fonctionne, au contraire de [[Joze Plečnik]]. J'ignore si cette information vous aide. Merci d'avance. --Fabusnow 2 janvier 2009 à 15:42 (UTC)
Ton explication est tout à fait possible puisque des caractères asiatiques avaient déjà il y a près d'un an apporté le même souci. Evitons les caractères non francophones le plus possible.--Macassardiscuter 2 janvier 2009 à 17:22 (UTC)
J’ai moi aussi tout le temps ce problème (je dirais une fois sur trois). Je suis sur un portable en Wi-fi avec une connectivité assez mauvaise. Peut-être que ça a un rapport ? --Eiku 26 mars 2009 à 17:54 (UTC)

Impossible d'importer une image[modifier]

Depuis ce matin, j'ai essayé à plusieurs reprises d'importer une image par le moyen traditionnel, que ce soit avec mes connexions principale ou de dépannage. À chaque fois, ce message s'affiche :

Connexion interrompue
La connexion avec le serveur a été réinitialisée pendant le chargement de la page.
La liaison au réseau a été interrompue pendant la négociation d'une connexion. Veuillez réessayer.

Partout ailleurs, y compris sur Vikidia, aucun problème.

D'autres que moi rencontrent-ils ce problème ? Confusion --Flodelaplage [Bla-bla] 6 février 2009 à 11:14 (UTC)

Déséquilibre signalé par le robot[modifier]

Je ne pense pas que cela ait une grande incidence, mais le robot signale un déséquilibre d'accolades en page d'accueil. Je ne vois pas où et le signale à toutes fins utiles. Flodelaplage [Bla-bla] 8 février 2009 à 12:21 (UTC)

Recherche impossible[modifier]

Voici ce qui s'affiche :

Erreur de la base de données Erreur de syntaxe dans la base de données. Cette erreur est peut-être due à une requête de recherche incorrecte (voir $5) ou une erreur dans le logiciel. La dernière requête traitée par la base de données était :

   (Requête SQL cachée)

depuis la fonction « Parser::replaceLinkHolders ». MySQL a renvoyé l’erreur « 1267 : Illegal mix of collations (latin1_bin,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' (localhost) ».

--Flodelaplage [Bla-bla] 24 février 2009 à 16:23 (UTC)

Fausse alerte. J'avais tapé « Mikołaj Kopernik » pour faire un redirect vers Nicolas Copernic. Cela provenait d'un copier-coller depuis l'encyclo Larousse, je n'avais pas vu qu'il y avait un signe un peu « bizarre » dans le lot, et le moteur de recherche n'aime apparemment pas ce genre de signe. --Flodelaplage [Bla-bla] 24 février 2009 à 16:29 (UTC)
Moui, c'était effectivement un bug qui a été corrigé après la migration. Bonne journée, Plyd (discussion) 28 février 2010 à 17:45 (UTC)

Proiblèmes graves ...[modifier]

Bonjour, j'ai un gros problème sur ce site ... Quand je poste un message, ça me le poste, mais après, dans les jours suivant, quand je reviens, je vois la même chose ... Par exemple, j'ai eu une discussion avec Plyd pour une "page isbn", le 3auot. Le 7 aout, je reviens et je retrouve la même page. J'ai beau repasser par google, vider le cache etc, rien n'y fait (c'est à tourner bourriqueJe ne comprends pas !La la lèreuh !. Pour visualiser la réponse, je doit télécharger un autre navigateur, et le problème réapparaît sur le nouveau navigateur. Comme je ne pourrais pas voir la réponse ... à moins de télécharger un autre navigateur ... Si on pouvait communiquer en attendant par E-mail, ça serait bien. [NB : E-mail enlevé par souci de protection de mineurs --Flodelaplage (discussion) 7 août 2010 à 14:24 (CEST)] Merci beaucoup, et à bientôt. Tartarin (discussion) 7 août 2010 à 14:03 (CEST)

Désolé, je ne vois pas du tout de là où ça pourrait venir. Sans doute un problème côté navigateur. Essaye de changer peut être que ça fonctionne mieux. Bon courage ! Plyd (discussion) 17 août 2010 à 11:40 (CEST)

{{Lien externe}}[modifier]

Bonjour. Je viens de parler de ce modèle à BEAUTEMPS. Or, la syntaxe courte indiquée ne fonctionne pas. Y aurait-il moyen d'arranger cela, en faisant en sorte que le paramètre langue ne soit pas obligatoire ? (Voir mon point de vue dans mon message à BEAUTEMPS.) --Flodelaplage (discussion) 1 décembre 2010 à 09:51 (CET)